Emergency maintenance
Incident Report for Miro
Resolved
This incident has been resolved. Apologies for the inconvenience!
Posted Mar 18, 2017 - 05:18 UTC
Identified
We have identified a critical error, which cannot be fixed while the application is running. Please check back in a couple of minutes, the application should become available shortly.
Posted Mar 18, 2017 - 04:48 UTC