Personal accounts board access issue
Incident Report for RealtimeBoard
Resolved
This incident has been resolved.
Posted 11 months ago. Aug 09, 2017 - 19:16 UTC
Identified
Some users cannot access their boards at the moment. We are working hard to resolve the issue, it will be fixed soon.
Posted 11 months ago. Aug 09, 2017 - 18:08 UTC