Desktop app update issue
Incident Report for Miro
Resolved
The issue has been resolved. Please accept our apology for the inconvenience this may have caused. If you’re still facing difficulties updating our desktop app, please open a ticket with our support team.
Posted Feb 28, 2018 - 12:30 UTC
Identified
We are experiencing technical issues with our desktop app update. While our engineering team is working on a fix, the current desktop app version can be used without an update.
Posted Feb 28, 2018 - 09:50 UTC